NetworkingLab

From Hackerspace Brussels
Jump to: navigation, search

did a first cisco 101 today 3rd of Nov 2011


The LantronixEts32pr devices are helpfull to communicate with multiple serial devices (eg. cisco devices).



enable
show running-config
show startup-config
show interfaces
show ?
show ip interface brief


configure terminal
interface FastEthernet 0/0
ip address 172.22.33.253 255.255.255.128
no shutdown
ctrl-z

ping 172.22.33.254

interface BRI 1/0
# this thing sucks: isdn thingies, not ethernet

# now for some routing
---------------------------------------------------------------------------------
Which one am I using?

blah#show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:21 by phanguye
Image text-base: 0x80008088, data-base: 0x80C524F8

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

blah uptime is 1 hour, 14 minutes
System returned to ROM by power-on
System image file is "flash:c2600-is-mz.120-7.T.bin"

cisco 2610 (MPC860) processor (revision 0x202) with 29696K/3072K bytes of memory.
Processor board ID JAD04011G0R (3749844627)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
-------------------------------------------------------------------------------------------------------







Chouffe#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            unassigned      YES unset  administratively down down    
FastEthernet0/1            unassigned      YES unset  administratively down down    
ATM0/0/0                   unassigned      YES unset  administratively down down    

FastEthernet0/1    10.0.0.1 /16   (cf leffe)
FastEthernet0/0     10.1.0.1/16  (nc)


configure terminal
interface FastEthernet 0/0
ip address 10.1.0.1 255.255.0.0
no shutdown
exit
configure terminal
interface FastEthernet 0/1
ip address 10.0.0.1 255.255.0.0
no shutdown
exit


Duvel>show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                172.16.50.1     YES manual up                    down    
Serial0/0                  unassigned      YES unset  administratively down down    
Ethernet1/0                172.16.55.1     YES manual up                    down    

duvel 
E 0/0                 192.168.1.1/24 (cf leffe)
ETHERNET ?/0   10.2.0.1/16   (nc)


configure terminal
interface Ethernet 0/0 
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
configure terminal
interface Ethernet 1/0
ip address 10.2.0.1 255.255.0.0
no shutdown
exit


leffe
FE 0/0 172.22.33.253/128
E ?/1   10.0.0.2/16  (cf chouffe)
E ?/0   192.168.1.2/24   (cf duvel)



[edit] packet tracer

Packet tracer.png

cisco has a simulation tool called packet tracer; it's great for experimenting with configs, but there's some strange quirks (eg. Just changing IP-addresses got me from a non-working situation to a working setup: 10.1.1.1/24 to 10.1.4.1/24)

# Leffe
# VLAN 10 10.1.1.2/24     
# VLAN 20 10.1.2.1/24
# VLAN 30 10.1.11.1/24

# Chouffe
# VLAN 10 10.1.2.2/24     
# VLAN 20 10.1.3.1/24
# VLAN 30 10.1.12.1/24

# Duvel
# VLAN 10 10.1.3.2/24     
# VLAN 20 10.1.1.1/24
# VLAN 30 10.1.13.1/24


# Leffe

ena
conf t
interface FastEthernet 0/0
no shutdown
exit
interface FastEthernet 0/0.10
enc dot1Q 10
ip address 10.1.4.2 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.20
enc dot1Q 20
ip address 10.1.2.1 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.30
enc dot1Q 30
ip address 10.1.11.1 255.255.255.0
no shutdown
exit
router rip
network 10.1.11.0
exit
exit


# Chouffe

ena
conf t
interface FastEthernet 0/0
no shutdown
exit
interface FastEthernet 0/0.10
enc dot1Q 10
ip address 10.1.2.2 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.20
enc dot1Q 20
ip address 10.1.3.1 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.30
enc dot1Q 30
ip address 10.1.12.1 255.255.255.0
no shutdown
exit
router rip
network 10.1.12.0
exit
exit


# Duvel

ena
conf t
interface FastEthernet 0/0
no shutdown
exit
interface FastEthernet 0/0.10
enc dot1Q 10
ip address 10.1.3.2 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.20
enc dot1Q 20
ip address 10.1.4.1 255.255.255.0
no shutdown
exit
interface FastEthernet 0/0.30
enc dot1Q 30
ip address 10.1.13.1 255.255.255.0
no shutdown
exit
router rip
network 10.1.13.0
exit

exit


# managed switch

enable
configure terminal

interface FastEthernet0/1
switchport mode trunk
exit
interface FastEthernet0/2
switchport access vlan 10
exit
interface FastEthernet0/3
switchport access vlan 10
exit
interface FastEthernet0/4
switchport access vlan 10
exit
interface FastEthernet0/5
switchport access vlan 20
exit
interface FastEthernet0/6
switchport access vlan 20
exit
interface FastEthernet0/7
switchport access vlan 20
exit
interface FastEthernet0/8
switchport access vlan 20
exit
interface FastEthernet0/9
switchport access vlan 30
exit
interface FastEthernet0/10
switchport access vlan 30
exit
interface FastEthernet0/11
switchport access vlan 30
exit